// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0\.\d{1,3}$").unwrap();
let string = "0
0.1
0.12
0.123
0.1234
00
00.1
00.12
00.123
00.1234
1
1.1
1.12
1.123
1.1234
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}