$re = '/^0\.\d{1,3}$/m';
$str = '0
0.1
0.12
0.123
0.1234
00
00.1
00.12
00.123
00.1234
1
1.1
1.12
1.123
1.1234
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);