use strict;
my $str = '0
0.1
0.12
0.123
0.1234
00
00.1
00.12
00.123
00.1234
1
1.1
1.12
1.123
1.1234
';
my $regex = qr/^0\.\d{1,3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}