using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<amount>¼|½|¾|\d+\/\d+|\d+)\s*(?<content>.*)$";
string input = @"2 fl. ounces paprika
3/4 fl.ounce paprika
1 Chopped Tomato
1/2 Cup yogurt
unclear amount of whatever
1 packet pasta
½ tsp fine sea salt
3 sliced onions
1/2 teaspoon heavy cream
2 ounces paprika
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}