const regex = /^(?<amount>¼|½|¾|\d+\/\d+|\d+)\s*(?<content>.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<amount>¼|½|¾|\\d+\\\/\\d+|\\d+)\\s*(?<content>.*)$', 'gm')
const str = `2 fl. ounces paprika
3/4 fl.ounce paprika
1 Chopped Tomato
1/2 Cup yogurt
unclear amount of whatever
1 packet pasta
½ tsp fine sea salt
3 sliced onions
1/2 teaspoon heavy cream
2 ounces paprika
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}