re = /^(?<amount>¼|½|¾|\d+\/\d+|\d+)\s*(?<content>.*)$/m
str = '2 fl. ounces paprika
3/4 fl.ounce paprika
1 Chopped Tomato
1/2 Cup yogurt
unclear amount of whatever
1 packet pasta
½ tsp fine sea salt
3 sliced onions
1/2 teaspoon heavy cream
2 ounces paprika
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end