package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<amount>¼|½|¾|\d+\/\d+|\d+)\s*(?<content>.*)$`)
var str = `2 fl. ounces paprika
3/4 fl.ounce paprika
1 Chopped Tomato
1/2 Cup yogurt
unclear amount of whatever
1 packet pasta
½ tsp fine sea salt
3 sliced onions
1/2 teaspoon heavy cream
2 ounces paprika
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}