const regex = /\b\d{4}\s+[A-Z]+(\d+)\b(?!\s+\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{4}\\s+[A-Z]+(\\d+)\\b(?!\\s+\\d)', 'gm')
const str = `RO41 RNCB 0089 0957 6044 0001 FPS21098343 RO17 BTRL 0470 1202 W949 45XX
RO41 RNCB 0089 0957 6044 0001 FPS21098343`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}