import re
regex = re.compile(r"\b\d{4}\s+[A-Z]+(\d+)\b(?!\s+\d)", flags=re.MULTILINE)
test_str = ("RO41 RNCB 0089 0957 6044 0001 FPS21098343 RO17 BTRL 0470 1202 W949 45XX\n"
"RO41 RNCB 0089 0957 6044 0001 FPS21098343")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")