$re = '/\b\d{4}\s+[A-Z]+(\d+)\b(?!\s+\d)/m';
$str = 'RO41 RNCB 0089 0957 6044 0001 FPS21098343 RO17 BTRL 0470 1202 W949 45XX
RO41 RNCB 0089 0957 6044 0001 FPS21098343';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);