re = /\b\d{4}\s+[A-Z]+(\d+)\b(?!\s+\d)/m
str = 'RO41 RNCB 0089 0957 6044 0001 FPS21098343 RO17 BTRL 0470 1202 W949 45XX
RO41 RNCB 0089 0957 6044 0001 FPS21098343'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end