# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\"[^"]*)\s*\")|((?:\'[^']*)\s*\')|((?:\`[^`]*)\s*\`)|((?:\b|\s){1}const\s{1})|((?:\b|\s){1}function\s{1})|((?:\b|\s){1}let\s{1})|(?:\\/\\/.*$)|(?:\\/\*+(?:.|\s)*\*\\/)|\s*/$1$2$3$4$5$6/gim;t' <<< "function myFunction() {
let carName = \"Volvo\";
// code here CAN use carName
const test = 'string with \"quoted substring\"'; let airplane = 'fly'
(\"and another string th'' as' asd 'ere\")
labelForStrings: {
`t'is a \"string\"`
}
}
/*asd *****
* 324 @*l;;?\\\
* multiline comment
*** /
*/"