package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)((?:\"[^"]*)\s*\")|((?:\'[^']*)\s*\')|((?:\`[^`]*)\s*\`)|((?:\b|\s){1}const\s{1})|((?:\b|\s){1}function\s{1})|((?:\b|\s){1}let\s{1})|(?:\/\/.*$)|(?:\/\*+(?:.|\s)*\*\/)|\s*`)
var str = `function myFunction() {
let carName = "Volvo";
// code here CAN use carName
const test = 'string with "quoted substring"'; let airplane = 'fly'
("and another string th'' as' asd 'ere")
labelForStrings: {
\`t'is a "string"\`
}
}
/*asd *****
* 324 @*l;;?\\\
* multiline comment
*** /
*/`
var substitution = "$1$2$3$4$5$6"
fmt.Println(re.ReplaceAllString(str, substitution))
}