const regex = /((?:\"[^"]*)\s*\")|((?:\'[^']*)\s*\')|((?:\`[^`]*)\s*\`)|((?:\b|\s){1}const\s{1})|((?:\b|\s){1}function\s{1})|((?:\b|\s){1}let\s{1})|(?:\/\/.*$)|(?:\/\*+(?:.|\s)*\*\/)|\s*/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\"[^"]*)\\s*\\")|((?:\\\'[^\']*)\\s*\\\')|((?:\\`[^`]*)\\s*\\`)|((?:\\b|\\s){1}const\\s{1})|((?:\\b|\\s){1}function\\s{1})|((?:\\b|\\s){1}let\\s{1})|(?:\\\/\\\/.*$)|(?:\\\/\\*+(?:.|\\s)*\\*\\\/)|\\s*', 'gim')
const str = `function myFunction() {
let carName = "Volvo";
// code here CAN use carName
const test = 'string with "quoted substring"'; let airplane = 'fly'
("and another string th'' as' asd 'ere")
labelForStrings: {
\`t'is a "string"\`
}
}
/*asd *****
* 324 @*l;;?\\\\\\
* multiline comment
*** /
*/`;
const subst = `$1$2$3$4$5$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);