import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=#00FF|#FF00)[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2}(?=00FF|FF00)|(?<=#00)[A-Fa-f0-9]{2}(?=FF)|(?<=#FF)[A-Fa-f0-9]{2}(?=00)";
final String string = "Correct cases:\n"
+ "#FF0012\n"
+ "#00FFAB\n"
+ "#0034FF\n"
+ "#CD00FF\n"
+ "#56FF00\n"
+ "#FF7800\n\n"
+ "Incorrect cases:\n"
+ "#0000AA\n"
+ "#FFFFBB\n"
+ "#00CC00\n"
+ "#FFDDFF\n"
+ "#EE0000\n"
+ "#FFFFFF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}