$re = '/(?<=#00FF|#FF00)[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2}(?=00FF|FF00)|(?<=#00)[A-Fa-f0-9]{2}(?=FF)|(?<=#FF)[A-Fa-f0-9]{2}(?=00)/m';
$str = 'Correct cases:
#FF0012
#00FFAB
#0034FF
#CD00FF
#56FF00
#FF7800
Incorrect cases:
#0000AA
#FFFFBB
#00CC00
#FFDDFF
#EE0000
#FFFFFF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);