import re
regex = re.compile(r"(?<=#00FF|#FF00)[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2}(?=00FF|FF00)|(?<=#00)[A-Fa-f0-9]{2}(?=FF)|(?<=#FF)[A-Fa-f0-9]{2}(?=00)", flags=re.MULTILINE)
test_str = ("Correct cases:\n"
"#FF0012\n"
"#00FFAB\n"
"#0034FF\n"
"#CD00FF\n"
"#56FF00\n"
"#FF7800\n\n"
"Incorrect cases:\n"
"#0000AA\n"
"#FFFFBB\n"
"#00CC00\n"
"#FFDDFF\n"
"#EE0000\n"
"#FFFFFF")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")