#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"(?P<street>\w+?[^\d\n]+)" & @CRLF & _
"(?P<nr>\d*[-\d]*)" & @CRLF & _
"(?P<adjective>[a-zA-Z]*)" & @CRLF & _
".*"
Local $sString = "St. edward's Lane 26" & @CRLF & _
"Vineyardlane3a" & @CRLF & _
"High Street 0-9" & @CRLF & _
"ParkRoad near #33" & @CRLF & _
"Queens Road ??" & @CRLF & _
"s-Georgelane9abc" & @CRLF & _
"Kings Road 9b" & @CRLF & _
"1st Park Avenue 67 near cyclelane "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")