import re
regex = re.compile(r"""
^
(?P<street>\w+?[^\d\n]+)
(?P<nr>\d*[-\d]*)
(?P<adjective>[a-zA-Z]*)
.*
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("St. edward's Lane 26\n"
"Vineyardlane3a\n"
"High Street 0-9\n"
"ParkRoad near #33\n"
"Queens Road ??\n"
"s-Georgelane9abc\n"
"Kings Road 9b\n"
"1st Park Avenue 67 near cyclelane ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")