re = /^
(?P<street>\w+?[^\d\n]+)
(?P<nr>\d*[-\d]*)
(?P<adjective>[a-zA-Z]*)
.*/mx
str = 'St. edward\'s Lane 26
Vineyardlane3a
High Street 0-9
ParkRoad near #33
Queens Road ??
s-Georgelane9abc
Kings Road 9b
1st Park Avenue 67 near cyclelane '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end