package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
(?P<street>\w+?[^\d\n]+)
(?P<nr>\d*[-\d]*)
(?P<adjective>[a-zA-Z]*)
.*`)
var str = `St. edward's Lane 26
Vineyardlane3a
High Street 0-9
ParkRoad near #33
Queens Road ??
s-Georgelane9abc
Kings Road 9b
1st Park Avenue 67 near cyclelane `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}