import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*function\\s+(?:(?:\\[((?:\\s*(?:\\w+[\\w0-9]*)\\s*,?)+)\\]|(\\w+[\\w0-9]*))\\s*=)?[\\s.]*(\\w+[\\w0-9]*)\\s*(?:\\(([^)]*)\\))?";
final String string = "function loss = conductionLo7ss (self, Irms, m, DPF)\n"
+ "function [loss, arg2] = conductionLoss (self, Irms, m, DPF)\n"
+ "function loss = gf (self, Irms, m, DPF)\n\n"
+ "function loss = gf(self, Irms, m, DPF)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}