import re
regex = re.compile(r"^\s*function\s+(?:(?:\[((?:\s*(?:\w+[\w0-9]*)\s*,?)+)\]|(\w+[\w0-9]*))\s*=)?[\s.]*(\w+[\w0-9]*)\s*(?:\(([^)]*)\))?", flags=re.MULTILINE)
test_str = ("function loss = conductionLo7ss (self, Irms, m, DPF)\n"
"function [loss, arg2] = conductionLoss (self, Irms, m, DPF)\n"
"function loss = gf (self, Irms, m, DPF)\n\n"
"function loss = gf(self, Irms, m, DPF)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")