re = /^\s*function\s+(?:(?:\[((?:\s*(?:\w+[\w0-9]*)\s*,?)+)\]|(\w+[\w0-9]*))\s*=)?[\s.]*(\w+[\w0-9]*)\s*(?:\(([^)]*)\))?/m
str = 'function loss = conductionLo7ss (self, Irms, m, DPF)
function [loss, arg2] = conductionLoss (self, Irms, m, DPF)
function loss = gf (self, Irms, m, DPF)
function loss = gf(self, Irms, m, DPF)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end