import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(var.*=)\\s+(([\\{\\[\\]][^\\{\\}\\n]*[\\n\\r]+(\\t[^\\r\\n]*)*[\\}\\]])|([^\\n]*))";
final String string = "var testmultiline = {\n"
+ " fizz = {\n"
+ " buzz = \"moo\"\n"
+ " }\n"
+ " buzz = {\n"
+ " buzz = \"moo\"\n"
+ " }\n"
+ "}\n\n"
+ "var testmultiline = {\n"
+ " fizz = {\n"
+ " buzz = \"moo\"\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}