$re = '/(var.*=)\s+(([\{\[\]][^\{\}\n]*[\n\r]+(\t[^\r\n]*)*[\}\]])|([^\n]*))/m';
$str = 'var testmultiline = {
fizz = {
buzz = "moo"
}
buzz = {
buzz = "moo"
}
}
var testmultiline = {
fizz = {
buzz = "moo"
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);