re = /(var.*=)\s+(([\{\[\]][^\{\}\n]*[\n\r]+(\t[^\r\n]*)*[\}\]])|([^\n]*))/m
str = 'var testmultiline = {
fizz = {
buzz = "moo"
}
buzz = {
buzz = "moo"
}
}
var testmultiline = {
fizz = {
buzz = "moo"
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end