import re
regex = re.compile(r"(var.*=)\s+(([\{\[\]][^\{\}\n]*[\n\r]+(\t[^\r\n]*)*[\}\]])|([^\n]*))", flags=re.MULTILINE)
test_str = ("var testmultiline = {\n"
" fizz = {\n"
" buzz = \"moo\"\n"
" }\n"
" buzz = {\n"
" buzz = \"moo\"\n"
" }\n"
"}\n\n"
"var testmultiline = {\n"
" fizz = {\n"
" buzz = \"moo\"\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")