#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55])\s.*"
Local $sString = ":start: chore(scope): test" & @CRLF & _
"chore(scope): test" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"👍 test:" & @CRLF & _
"" & @CRLF & _
"🤣 heel:" & @CRLF & _
"" & @CRLF & _
"😌 chore(scope): test" & @CRLF & _
"" & @CRLF & _
"✨ feat(unicode): add unicode support" & @CRLF & _
"" & @CRLF & _
"♻️ refactor: add unicode support" & @CRLF & _
"" & @CRLF & _
"⬆️ deps: bump commitlint version" & @CRLF & _
"" & @CRLF & _
"⚡️ perf: add unicode support"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")