using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55])\s.*";
string input = @":start: chore(scope): test
chore(scope): test
👍 test:
🤣 heel:
😌 chore(scope): test
✨ feat(unicode): add unicode support
♻️ refactor: add unicode support
⬆️ deps: bump commitlint version
⚡️ perf: add unicode support";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}