package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55])\s.*`)
var str = `:start: chore(scope): test
chore(scope): test
👍 test:
🤣 heel:
😌 chore(scope): test
✨ feat(unicode): add unicode support
♻️ refactor: add unicode support
⬆️ deps: bump commitlint version
⚡️ perf: add unicode support`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}