$re = '/(\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55])\s.*/m';
$str = ':start: chore(scope): test
chore(scope): test
👍 test:
🤣 heel:
😌 chore(scope): test
✨ feat(unicode): add unicode support
♻️ refactor: add unicode support
⬆️ deps: bump commitlint version
⚡️ perf: add unicode support';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);