#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sm)(?(?=.*?^\h*param\h*=\N*).*?\K^\h*param\h*=\N*|.*?\K^\h*#+\h*param\h*=\N*)"
Local $sString = " ### param = 1" & @CRLF & _
"# param = 2" & @CRLF & _
"# param = 3" & @CRLF & _
"" & @CRLF & _
"param = 4" & @CRLF & _
"" & @CRLF & _
"# param = 5" & @CRLF & _
""
Local $sSubst = "${2}7"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)