const regex = new RegExp('(?(?=.*?^\\h*param\\h*=\\N*).*?\\K^\\h*param\\h*=\\N*|.*?\\K^\\h*#+\\h*param\\h*=\\N*)', 'sm')
const str = ` ### param = 1
# param = 2
# param = 3
param = 4
# param = 5
`;
const subst = `${2}7`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);