$re = '~(?(?=.*?^\h*param\h*=\N*).*?\K^\h*param\h*=\N*|.*?\K^\h*#+\h*param\h*=\N*)~sm';
$str = ' ### param = 1
# param = 2
# param = 3
param = 4
# param = 5
';
$subst = "${2}7";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;