using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9]+((_|-|\.)?[a-zA-Z0-9])*$";
string input = @"john
john.
john.doe
john80
john_doe
john__doe
TESTUSER_john_doe
_john
john_doe_
john doe
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}