package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]+((_|-|\.)?[a-zA-Z0-9])*$`)
var str = `john
john.
john.doe
john80
john_doe
john__doe
TESTUSER_john_doe
_john
john_doe_
john doe
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}