# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?(?:Keywords:?\s)(.*?,.*?,.*?(?<!,)(?=\s[A-Z])){1,2}.*?$//gm;t' <<< "This is a random text Keywords AA, bB, CC Hi stack overflow
Hi stackoverflow Keywords: a, b, Stack Overflow Some more text"