using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?(?:Keywords:?\s)(.*?,.*?,.*?(?<!,)(?=\s[A-Z])){1,2}.*?$";
string substitution = @"";
string input = @"This is a random text Keywords AA, bB, CC Hi stack overflow
Hi stackoverflow Keywords: a, b, Stack Overflow Some more text";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}