$re = '/.*?(?:Keywords:?\s)(.*?,.*?,.*?(?<!,)(?=\s[A-Z])){1,2}.*?$/m';
$str = 'This is a random text Keywords AA, bB, CC Hi stack overflow
Hi stackoverflow Keywords: a, b, Stack Overflow Some more text';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;