#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)("version"\s*:\s*)(\d+)"
Local $sString = "{" & @CRLF & _
" "revision" : {" & @CRLF & _
" "clientId" : "dc572274-4b71-11b6-e415-b91e391bcf4d"," & @CRLF & _
" "version" : 7" & @CRLF & _
" }," & @CRLF & _
" "id" : "dc572260-4b71-11b6-0371-f73573ab44fe"," & @CRLF & _
" "uri" : "http://x.x.x.x:9090/nifi-api/processors/dc572260-4b71-0371-73ab44fe"," & @CRLF & _
" "position" : {" & @CRLF & _
" "x" : -1021.9568138214972," & @CRLF & _
" "y" : 333.2029958718132" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")