import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(\"version\"\\s*:\\s*)(\\d+)";
final String string = "{\n"
+ " \"revision\" : {\n"
+ " \"clientId\" : \"dc572274-4b71-11b6-e415-b91e391bcf4d\",\n"
+ " \"version\" : 7\n"
+ " },\n"
+ " \"id\" : \"dc572260-4b71-11b6-0371-f73573ab44fe\",\n"
+ " \"uri\" : \"http://x.x.x.x:9090/nifi-api/processors/dc572260-4b71-0371-73ab44fe\",\n"
+ " \"position\" : {\n"
+ " \"x\" : -1021.9568138214972,\n"
+ " \"y\" : 333.2029958718132\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}