// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)("version"\s*:\s*)(\d+)"#).unwrap();
let string = "{
\"revision\" : {
\"clientId\" : \"dc572274-4b71-11b6-e415-b91e391bcf4d\",
\"version\" : 7
},
\"id\" : \"dc572260-4b71-11b6-0371-f73573ab44fe\",
\"uri\" : \"http://x.x.x.x:9090/nifi-api/processors/dc572260-4b71-0371-73ab44fe\",
\"position\" : {
\"x\" : -1021.9568138214972,
\"y\" : 333.2029958718132
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}