use strict;
my $str = '{
"revision" : {
"clientId" : "dc572274-4b71-11b6-e415-b91e391bcf4d",
"version" : 7
},
"id" : "dc572260-4b71-11b6-0371-f73573ab44fe",
"uri" : "http://x.x.x.x:9090/nifi-api/processors/dc572260-4b71-0371-73ab44fe",
"position" : {
"x" : -1021.9568138214972,
"y" : 333.2029958718132
}
}';
my $regex = qr/(?s)("version"\s*:\s*)(\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}