#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9]{3,8}-\d{1}$"
Local $sString = "# Genuine values" & @CRLF & _
"63638-1" & @CRLF & _
"8867-4" & @CRLF & _
"55231-5" & @CRLF & _
"26464-8" & @CRLF & _
"22577-1" & @CRLF & _
"# Checking edge cases" & @CRLF & _
"12-1" & @CRLF & _
"123-1" & @CRLF & _
"12345678-9" & @CRLF & _
"123456789-9" & @CRLF & _
"12345678" & @CRLF & _
"12345678-" & @CRLF & _
"12345678--" & @CRLF & _
"12345678-A" & @CRLF & _
"12345678-?" & @CRLF & _
"12345678-12" & @CRLF & _
"# Adding letters to the main code" & @CRLF & _
"LL2435-7" & @CRLF & _
"LL358-3" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")