const regex = /^[a-zA-Z0-9]{3,8}-\d{1}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z0-9]{3,8}-\\d{1}$', 'gm')
const str = `# Genuine values
63638-1
8867-4
55231-5
26464-8
22577-1
# Checking edge cases
12-1
123-1
12345678-9
123456789-9
12345678
12345678-
12345678--
12345678-A
12345678-?
12345678-12
# Adding letters to the main code
LL2435-7
LL358-3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}