import re
regex = re.compile(r"^[a-zA-Z0-9]{3,8}-\d{1}$", flags=re.MULTILINE)
test_str = ("# Genuine values\n"
"63638-1\n"
"8867-4\n"
"55231-5\n"
"26464-8\n"
"22577-1\n"
"# Checking edge cases\n"
"12-1\n"
"123-1\n"
"12345678-9\n"
"123456789-9\n"
"12345678\n"
"12345678-\n"
"12345678--\n"
"12345678-A\n"
"12345678-?\n"
"12345678-12\n"
"# Adding letters to the main code\n"
"LL2435-7\n"
"LL358-3\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")