use strict;
my $str = ' EEC001 1EECOL ELECTRIC CORP CANOE PROCUREMENT GROUP
EEC001 EECOL ELECTRIC CORP CANOE PROCUREMENT GROUP ';
my $regex = qr/^\s+\S+\s+([\dA-Z][A-Z\d\s]+?)\s{2,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}