$re = '/^\s+\S+\s+([\dA-Z][A-Z\d\s]+?)\s{2,}/m';
$str = ' EEC001 1EECOL ELECTRIC CORP CANOE PROCUREMENT GROUP
EEC001 EECOL ELECTRIC CORP CANOE PROCUREMENT GROUP ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);