re = /^\s+\S+\s+([\dA-Z][A-Z\d\s]+?)\s{2,}/m
str = ' EEC001 1EECOL ELECTRIC CORP CANOE PROCUREMENT GROUP
EEC001 EECOL ELECTRIC CORP CANOE PROCUREMENT GROUP '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end